Jump to content

How can I copy files to the X5 from my laptop?

Lovell McIlwain

Recommended Posts


I am attempting to copy my backup Kodi files to the X5 and I am having some trouble.

So far I have tried using ES File Explorer and X-plore to copy files from my laptop to the X5 but neither of them have worked and I can't seem to track down why.

ES File Explorer just fails for every action I attempt whether it's uploading a file through the "View on PC" or deleting a file through the app itself.

X-plore just doesn't show the content of the directory when I attempt to go to the path that I created.

As far as I am aware,  I am not attempting to access any system files and I made sure to force-stop Kodi just in case any files were in use but I am still not able to copy files. 

Has anyone else run into this issue or know of a way I can successfully upload files?


Link to comment
Share on other sites

I haven't used ES for ages.  But I regularly transfer files to/from my buzz boxes  (including the X5) and my Synology NAS server using Solid Explorer.  Should be pretty much the same as any windows SMB share (assuming no permission restrictions).  

However if you can't seen to set that up, you can always just copy files using a USB stick.


  • Like 1
Link to comment
Share on other sites

I just tried Solid Explorer and it told me I needed to downgrade to use it?

I have never tried to copy files using a USB stick but I can certainly give that a shot. I can't be that hard to figure out.

From what I can tell having messed with this for hours, I am expecting to see files in /storage/emulated/0/Android/data. So far every directory in the data directory appears to be empty. Even if I could attach a USB stick to the x5, I honestly don't know how to get to the directories I need to.

Doing a little research, there is some way I can connect the x5 directly to my laptop and that should give me access to the entire file system. I have a Mac so I am not sure if it's relevant but when I connected to my laptop, I didn't see a disk pop up as I expected it to. 

Link to comment
Share on other sites

I saw another post that you suggested teamviewer and I ran into a different yet same problem.

As I was navigating the directories on the x5 through teamviewer, I would get to the data directory and it would dump me right back to the root directory. It would just keep going in circles like that. It was like the data directory was a symlink back to the root directory or like a crash where it would reset the directory location back to the root directory. It was just weird.

Link to comment
Share on other sites

PS: Live links are not allowed 😞  Need to put in "code" tags.

So it looks like the default kodi data location is "protected" by the OS, and therefore you can't modify the contents (normally).  At least Kodi gives you the option to relocate it's data directory, but this will obviously not be the case with other apps.

Thanks for posting on what worked for you (and not just leaving the thread hanging).  It is probably not specific to the X5, so I'm sure it can help others.

I just checked and the version of Solid explorer I use is 2.8.13 and it works fine.  Guess newer versions don't like AndroidTV yet  



Link to comment
Share on other sites

Sorry about posting the live link. I don't seem to be able to edit the post to correct it 😞 

Yes, I agree. This is definitely not an X5 issue at all and definitely thankful that I am able to use another location for Kodi's data.

This is my first Android 11 device (coming from amazon cube) so I wasn't entirely sure what I was dealing with. I remember hearing about the permissions changes and how much trouble it was causing to existing users but I figured by now there might have been a way to "get around it".  Based on some of the suggestions, I'm guessing that is the case. Just in my particular case, nothing worked. I thought the same thing regarding other apps using the protected directory location but so far this is the only app where I copy files back and forth since I have multiple devices that I "sync" updates and whatnot.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...