Jump to content

Peacock app not prompting to authenticate

Dave Irwin

Recommended Posts

  I have tried installing several different versions of Peacock on this device but I don't get properly directed to the Peacock web pages during 1st app launch after install to complete setup for this particular device.    Do I need a particular apk to use on this device I recently purchased ( BuzzTV Classic 64GB Launch Edition × 1 ).   I have also tried to make sure my device was up to date where possible since it is newly out of the box.  Any advice ?



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...