Jump to content

General USB plugin information


Recommended Posts

Hello. I cannot find any information about this subject so in a slightly desperate way I have looked to this forum.


Recent purchase of "quality" smart box in hopes that it would perform as a general media centre. Including media on USB sticks etc as well as streaming content.


I have two self powered 6TB USB drives and have plugged both of these into the higher spec port provided. In both cases the box appears to be somewhat dismissive of the 

devices and has pretty much rejected both and even rebooted several times. It is pretty much refusing to engage with my devices and I wondered if I was doing something 

wrong. Is there anything that can be done to arrange a more productive exchange between these units?


Link to comment
Share on other sites

When you say "self powered" do you mean they get their power from the USB connection, or that they have their own external power supply ?  

Also, when you say it is dismissive, is it because it does not recognize your partitions, or the drive as a whole ?

Have you tried going into settings, and and then under storage, and seeing if it sees the drive itself (even thought it may not recognize the partition) ? 

It may not recognize the formatting on the drive.  I'm assuming you formatted the drive on a windows machine ?  The fact that it is 6TB, it was initialized as GPT, and not MBR ?   And assuming NTFS filesystem if you have 1 large 6TB volume ?

Considering the xrs4000 is an older device (running Android 9 if I recall - could be wrong), not sure what built in support it has for GPT vs MBR disks.  And also the FAT32/exFAT/NTFS  support.  And for NTFS, it depends on which version, since it has evolved quite a bit.

I rarely use any large disks (anything more than 2TB)  on my devices, since all my media is streamed from my NAS with one large 96TB volume.  I don't have a 4000, but I do have a 4500 (which is pretty close).  And the largest single disk I have are a few 4TB La Cie externally power USB drives, so I can run a few tests later this weekend.  

Over the years there were many limitations in windows and many linux.android kernels, in regards to max disk sizes they supported, max partition sizes they supported (ie: 2TB classis limit), and even partition types/version they supported.  So obviously if the drives are good, you are surely running into one of these limitations.



Link to comment
Share on other sites

  • 3 weeks later...

Yes they both are 1 block 6 TB drives and they both have their own power adapter supply. Not powered from any other device. I have tried looking up the drive in the settings menu only to find out that the device has been automatically ejected before I get a chance to do anything else.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...