Jump to content

Check Device Power

Recommended Posts

Hello everyone

I recently bought Buzz TV Vidstick ST4000. 

Setup went smooth till it prompted to update the firmware. 

After firmware update, I tried to add IPTV credential and the remote started lagging or freezing. I was unable to finished the setup and it forced restarted. 

Since then, its showing "Check Device Power" message continuously. I have tried the following steps but all in vain. 

1) Changed the HDMI Ports. 

2) Changed the power Cable and adapter

3) Reset my TV which is Samsung AU7000 series

4) Tried to reset the Stick 

Despite all of this stuff its still showing that message. I have Amazon Firestick which is working smooth in all three HDMI Ports. 

I really appreciate if any of the members can assist with this issue as its really driving crazy. The device was just delivered and during setup it all started. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...